ClinicCases Forum

Welcome!

It looks like you're new here. If you want to get involved, click one of these buttons!

ClinicCase Version 7.2.9 - cannot add New Cases

edited January 2017 in General
I just got ClinicCase Version 7.2.9 (released 7 days ago) running on Ubuntu 16.04.1 LTS with php 7.0.13 and mysql 5.7.17. All features seem to work fine for the start. But my issue is - I cannot add New Cases, the fields to populate just don't appear as expected when clicked on the "New Case" button. This is when logged on either as an admin and super admin. Hence I am being stuck from the start. Has anyone got this issue as well or should I tweak some setting somewhere to rectify this?

Comments

  • Check your apache and mysql logs. It's possible that your mysql installation is running in safe mode, which is the default for the newer versions of Ubuntu. I plan to do a release that works in safe mode, but for the meantime you should just disable it, if this is in fact the problem. https://gist.github.com/stormwild/5746860
  • edited February 2017
    I had Safe Mode turned off but no luck. There seem to be no entry in the mysql log but in the apache2 error.log, for every click on the 'New Case' button, I got an entry in the log with something like: file_get_contents(https://cliniccases.com/bug-reporter/reporter.php): php_network_getaddresses: getaddrinfo failed: I reinstalled everything several times, including ubuntu, still no joy.

    After days of losing sleep over this, I switched to CentOS 7 with mariadb. To my relief - ClicnicCases is now working perfectly fine - great software! I am using this in my country's only post graduate law intern school (before admission). This is for the school to manage Free Legal Aid cases assigned to the Trainees as part of the syllabus.

    Thank you!

    Gibson
    Port Moresby
    Papua New Guinea
  • I'm glad it worked out and glad you are enjoying ClinicCases. It seems like this was a problem with getting the host name of your machine in the bug reporter, which is not a bug I've encountered before.
Sign In or Register to comment.