ClinicCases Forum

Welcome!

It looks like you're new here. If you want to get involved, click one of these buttons!

Cannot Create "New Cases" (Cannot read property)

Dear Support,

I setup a new instance of your wonderful system (Version 7.3.3) on my own server (Ubuntu 16.04/PHP (7.0.33)/ MySQL (14) / Apache (2.4.18) and followed the instructions on setting the server up to the letter (https://cliniccases.com/documentation/#!installation.md).

However, I'm facing an issue when trying to create a "New Case" - simply put, absolutely nothing happens. When I check developer tools within my chrome browser, it informs me the following;

Uncaught TypeError: Cannot read property 'error' of null Cases.js:155
at Object.success (Cases.js:155)
at Function.handleSuccess (jquery-1.4.4.min.js:142)
at XMLHttpRequest.w.onreadystatechange (jquery-1.4.4.min.js:141)


When I go into the "Cases.js" file on line 155 it shows me that there is an error at

if (serverResponse.error === true)


However, I have no idea what the issue is on this particular line. If I hover my mouse over the "X" mark it says "Uncaught TypeError: Cannot read property 'error' of null"


Please note that;

- I'm not a pro developer.

- This is a fresh installation, no data has been entered / db modified.

- I'm using http and not https

- I have done the installation 3 times now, same result.

- All the other "New" functions such as "New User", "New Journal", "New Board", etc all works fine, its just the most important function of "New Case" which doesnt.

I hope you will be able to let me know how to fix this as I feel that it might be a bug. The demo was fantastic!

Comments



  • Guys, I seemed to have missed a post titled "ClinicCase Version 7.2.9 - cannot add New Cases".

    It seems that you need to have MYSQL Safe Mode turned off! It works after doing that. For reference purposes, Im going to indicate what I did to get this working in case someone else out there faced the same issue;

    - I followed article https://vpsfix.com/5266/disable-strict-mode-mysql-5-7-ubuntu-16-04/

    - This applies to Ubuntu 16.04 running Apache/MySQL/PHP

    1) Create a new .cnf file using your favorite editor - I used vi but you can use nano
    (sudo vi /etc/mysql/conf.d/strict_mode.cnf)

    2) Paste the following code into that file;

    [mysqld]
    sql_mode=IGNORE_SPACE,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

    3) Save and close the file ("ESC" button - type : - type wq)

    4) And then restart MySQL server (sudo systemctl restart mysql)
Sign In or Register to comment.